Blackboard CE8 Virtual Learning Environment

Announcement:

Blackboard CE8 will not be used for any new courses from September 2014 onwards, after that point new courses will be available on Blackboard Learn, if you can't see the course you want after logging in to CE8 it may already be available on Learn; Check which version of Blackboard you should be using.

Common Problems:

Accepting Java - prompt after login

After login you may be prompted by a security window asking for verification to run applications. You need to click Run to ensure that you enable Java functionality. More information about Java.

If you have problems logging in, go to http://vle.imperial.ac.uk and try logging in again.
If you still have problems logging in after this try the VLE Troubleshooter

Blackboard CE8 DOES NOT SUPPORT GOOGLE CHROME. Please use Firefox, IE or Safari to login.

WARNING: Do not bookmark this page directly - use one of the methods below.

If you use Internet Explorer click here to make a bookmark
If you use Firefox or Safari click and drag Blackboard to your 'Bookmarks Toolbar'




Forgotten Your Password?